MouseCraft Alfa – post your feedback here

home Forums MouseCraft MouseCraft MouseCraft Alfa – post your feedback here



This topic contains 48 replies, has 32 voices, and was last updated by kattanaita kattanaita 3 years, 4 months ago.

Viewing 15 posts - 16 through 30 (of 49 total)
  • Author
    Posts
  • #3497

    voodooray
    Member

    Joined: 8/3/2013

    Posts: 1

    Hi, love the game from what I was able to play in the beta release. The design seems perfectly suited to mobile devices, but don’t see it mentioned under the different targeted platforms. Hope you are successful in the project enough to port it over later on. Greenlit, and bought, best of luck!

    #3498

    Nhor
    Member

    Joined: 2/9/2013

    Posts: 1

    Puzzle mode is awesome but arcade mode is way too easy and too tiresome.

    How did I go through it? Pretty much by placing normal blocks where I wanted to and each time I got a TNT, crumbling or electric block I just built it anywhere and then destroyed it not to waste the place in queue for other blocks. Also in the last level (10th) of arcade mode all of the starting blocks are destructible. It makes no purpose for me – it takes only to destroy them and place some other blocks to get to the end of the level.

    How to fix it? Here are my ideas and I think they are pretty much reasonable.
    1) Don’t spawn TNT and electric blocks because they just occupy places in the queue. When I got one I just destroyed it – that’s what I found tiresome in arcade mode.
    2) Make a limited number of destructions that can player perform. It will make the game a little bit harder and force one to think, not just wait for appropiate block.
    3) Definitelly make the starting blocks indestructible.
    4) I don’t remember in which level was it but I do recall that I must have started the game for a few times until I got an appropiate block to move on because my mice were sinking in the water or acid. There are some ways to fix it and I believe you will find the best one. I think that levels like this should be spawning few constant blocks in the beginning to make sure it is possible to get through some difficulities not just by starting the game many times and waiting for exact block.

    #3506

    jolleward1@hotmail.com
    Member

    Joined: 8/1/2013

    Posts: 2

    i have only found 1 bug so far, the game drops a bit of FPS when you destroy a block.

    #3509

    Chrissu
    Member

    Joined: 8/7/2013

    Posts: 2

    When I toggle the windowed screen mod on and I enter the game, I see a black screen like this: http://i.imgur.com/zsptGJI.png I had to wait about 5 minutes for the unfreeze.

    My OS is Windows 8 x64. :P

    #3520

    twoflower@t-online.de
    Member

    Joined: 8/7/2013

    Posts: 3

    Ok, been through the puzzle mode now. So the comments are only for that (gave my feedback also in the endsurvey):
    I like the animations (especially the ghosts)
    The bricks should not be in the same order they are to be used to solve the puzzle. At the moment only from lvl 10 on it really makes sense not to use them as they are provided. I think the players can cope “thinking” a little earlier…
    There should be a little bonus for using less bricks than provided to solve the puzzle. For lvl 20 for instance I needed only two bricks and somehow expected at least a verbal comment for the “creative” and “economic” use of resource (this is a lab and grants are limited :-) …).
    THe scientist could use a little variety in motions. He could hold and scribble onto a pad or from time to time utter something like “aw come on, this is really simple”… we as players are meant to be underpaid (surely) lab assistants so we should be “encouraged”.
    Otherwise I absolutely loved the game and am really looking forward to the next 80+ levels. Did not encounter a single bug so far.

    #3524

    Akien
    Member

    Joined: 8/8/2013

    Posts: 9

    I played the first 12 puzzle levels or so for now, and really enjoyed it, you did a great job!

    One bug that I met: when switching from one level to the next, the background scrolling animation probably does not work as intended. It scrolls quite quickly (I think that’s intended), but it lasts around 10 seconds on my computer, so I just see the background scrolling for ten seconds. I also noticed that I can hit “Escape” during the transition and chose to restart the level. I then end up in an empty zone between the two levels, that I am supposed to play as if I was in the next level (see attached screenshot). I can use the whole interface as in a normal level; if I try once again to restart the level, I stay in this in-between. I can then go back to the main menu and start a new level, without any problem.

    I’m running the latest version of MouseCraft on Mageia 3 32bit. My embedded graphical chipset is nowadays quite low-end, so I run the game with low details, fullscreen mode with 1280×800 screen size.

    Attachments:
    You must be logged in to view attched files.
    #3526

    Akien
    Member

    Joined: 8/8/2013

    Posts: 9

    Another small issue, that is visible e.g. on level 12 of the puzzle mode.

    This level has 3 mice and 4 crystals, but when you complete it, the flying score box shows at first 0/3 mice (which is the intended behaviour) but also 0/3 crystals instead of 0/4. Then when the mice are counted it switches to 0/4 crystals before going upward (up to 4/4 crystals).

    #3529

    Akien
    Member

    Joined: 8/8/2013

    Posts: 9

    Hello,

    I’ve found 2 bugs on the level 16.

    I’ll attempt to explain to you but my english is not good… :s

    The first bug I’ve found is a “ghost” bloc but when I’ve restarted the game, the bug doesn’t apeared anymore. The second bug is mouses stay on air after I’ve destroyed the bloc where was it.

    I’m not sure what pip99 meant with “ghost” bloc, I don’t see what’s wrong on the first screenshot.
    I run into the second bug though, when trapping the mice between the two walls and destroying the block afterwards. See my first two screenshots (before and after destroying the block).

    I was playing through the Alpha and I hit a minor bug. On puzzle level 16 I got all three mice to the end and all the lights lit up, but the last mouse didn’t get counted on the counter or cause the level to end.

    I also ran into this bug on level 16, but I can’t reproduce it each time. I hint it might have to do with the use of the accelerated mode, then some actions are not always taken into account (see below). Undo the last block placement/destruction in normal speed mode fixed it, all three mice were then acknowledged by the cheese.

    Another bug I hit, still on level 16. When playing in accelerated mode, the second crystal might not be collected though the mice are supposed to be able to take it. It is reproductible, but not every time (most of the time, though). When playing in normal speed mode, the first mouse takes the crystal, as it is supposed to. See my third (accelerated mode) and fourth (normal speed mode) screenshots.

    My hint is that the engine might not have time to acknowledge the mice passing on the crystal tile when playing in accelerated mode, especially since my computer is old, so I experience a small lag.

    Attachments:
    You must be logged in to view attched files.
    #3534

    Akien
    Member

    Joined: 8/8/2013

    Posts: 9

    I run into the second bug though, when trapping the mice between the two walls and destroying the block afterwards. See my first two screenshots (before and after destroying the block).

    The screenshots above are not displayed in the correct order so look at their URLs. Those two are those labelled MouseCraft_BugLvl16_Before.png and MouseCraft_BugLvl16_After.png.

    Another bug I hit, still on level 16. When playing in accelerated mode, the second crystal might not be collected though the mice are supposed to be able to take it. It is reproductible, but not every time (most of the time, though). When playing in normal speed mode, the first mouse takes the crystal, as it is supposed to. See my third (accelerated mode) and fourth (normal speed mode) screenshots.

    The accelerated mode screenshot is MouseCraft_BugCrystal.png and the normal speed one is MouseCraft_BugCrystal_Slow.png.

    #3537

    Akien
    Member

    Joined: 8/8/2013

    Posts: 9

    Another bug I just hit, though it has more to do with the alpha-testing than the product in itself: When completing the in-game survey on Linux, I’m unable to type text in the “How much would you like to pay?” field and the free comment section. Too bad, I would have given a good price for it ;) (Okay I already bought it, but still).

    #3543

    Garvine
    Member

    Joined: 8/13/2013

    Posts: 1

    Not so much a bug. But just general feedback. I think you should consider adding a tooltip that you can delete blocks by RMB. I figured this out myself and it is a little intuitive, but nowhere in the introduction does it tell you that you can do this. I mean its not game breaking, but can be helpful to some people.

    Also consider revising the speed and animations for scrolling across with the keyboard keypad. It goes too fast and if you hold down the direction key even though it has reached the end of the screen it stutters and shakes the screen. Consider making it a stable screen.

    #3545

    designR
    Member

    Joined: 8/13/2013

    Posts: 2

    when i start the game in windowed mode, menu is fine but levels not loading. just the play,forward and other elements of hud showing on a black screen.
    options : 1920*1080-Windowed-High

    #3548

    Sunflowers
    Member

    Joined: 4/7/2013

    Posts: 2

    I’ve played the Alpha release and I very much like this game. The graphics are excellent, the concept is fun and I like the music at the start. I also like the Steampunk style. I’ve tested Beta versions for another company so I wasn’t quite sure about an Alpha release. I played it twice. It crashed on me the first time at level 13 and I had to CTL ALT DEL to bring up the Task Manager and close it down, but I had no problems the second time I played it about 5 minutes later.

    There was a mention of a Store in one of the early levels where we could buy items with the blue crystals we gathered. This would have been useful later because I couldn’t get past level 16! I could have done either with the brick breaker I had in round 15 carrying over to round 16 or the option of buying one in the Store because I was faced with two bricks which needed breaking. I managed to get one of the mice to the cheese, but the other two either couldn’t get past the brick I’d placed to stop them falling too far, met nasty ends or else couldn’t get past what was left of the original bridge over the acid.

    It’s a very addictive game and I really enjoyed it. I look forward to the full version when it comes out!

    #3549
    mantisghost
    mantisghost
    Member

    Joined: 8/12/2013

    Posts: 1

    Don’t want to make new thread so i will just post here.

    1. I can’t login to beta program when i type in email the birdie is green when i type either my new password ro old from the email i still have red X and not active login with email button.

    2. You can not copy/paste email and password to the fields ingame please make something with that as i am lazy ;)

    #3552

    Ceron
    Member

    Joined: 8/13/2013

    Posts: 1

    Level 10 and Level 20 can be completed without using all of the objects. Level 10 can be beaten with only three delete tokens (four given). Level 20 doesn’t even need the 2×2 square block. I’m made two Imgur albums to try to illustrate how to do it.

    http://imgur.com/a/qZ0dH#0

    http://imgur.com/a/hu6i4#0

Viewing 15 posts - 16 through 30 (of 49 total)

You must be logged in to reply to this topic.