Player is already running

home Forums MouseCraft MouseCraft Player is already running



This topic contains 2 replies, has 2 voices, and was last updated by  Trizt 3 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #5208

    Trizt
    Member

    Joined: 8/3/2013

    Posts: 1

    I was trying to play a few new levels today, but the game didn’t start, so I tried it from command line and got the following output:

    Found path: /usr/games/mousecraft/MouseCraft.x86
    Mono path[0] = ‘/usr/games/mousecraft/MouseCraft_Data/Managed’
    Mono path[1] = ‘/usr/games/mousecraft/MouseCraft_Data/Mono’
    Mono config path = ‘/usr/games/mousecraft/MouseCraft_Data/Mono/etc’
    Player is already running

    (Filename: Line: 413)

    I tried to run it as different users, but the same result.

    When running it with strace I get the following output in the end:

    munmap(0xfffffffff779f000, 4096) = 0
    lstat64(“/opt”, {st_mode=S_IFDIR|0755, st_size=4096, …}) = 0
    lstat64(“/opt/google”, {st_mode=S_IFDIR|0755, st_size=8, …}) = 0
    lstat64(“/opt/google/chrome”, {st_mode=S_IFDIR|0755, st_size=4096, …}) = 0
    lstat64(“/opt/google/chrome/chrome –type=zygote”, 0xfffffffffff6cf50) = -1 ENOENT (No such file or directory)
    open(“/proc/25630/cmdline”, O_RDONLY) = 4
    fstat64(4, {st_mode=S_IFREG|0444, st_size=0, …}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xf779f000
    read(4, “/proc/self/exe–type=gpu-proces”…, 4096) = 269
    read(4, “”, 3072) = 0
    close(4) = 0
    munmap(0xfffffffff779f000, 4096) = 0
    lstat64(“/proc”, {st_mode=S_IFDIR|0555, st_size=0, …}) = 0
    lstat64(“/proc/self”, {st_mode=S_IFLNK|0777, st_size=0, …}) = 0
    readlink(“/proc/self”, “14348″, 4095) = 5
    lstat64(“/proc/14348″, {st_mode=S_IFDIR|0555, st_size=0, …}) = 0
    lstat64(“/proc/14348/exe”, {st_mode=S_IFLNK|0777, st_size=0, …}) = 0
    readlink(“/proc/14348/exe”, “/usr/games/mousecraft/MouseCraft”…, 4095) = 36
    lstat64(“/usr”, {st_mode=S_IFDIR|0755, st_size=4096, …}) = 0
    lstat64(“/usr/games”, {st_mode=S_IFDIR|0755, st_size=16, …}) = 0
    lstat64(“/usr/games/mousecraft”, {st_mode=S_IFDIR|0755, st_size=24, …}) = 0
    lstat64(“/usr/games/mousecraft/MouseCraft.x86″, {st_mode=S_IFREG|0755, st_size=16617452, …}) = 0
    write(1, “Player is already running\n”, 26Player is already running
    ) = 26
    write(1, ” \n”, 2
    ) = 2
    write(1, “(Filename: Line: 413)\n\n”, 24(Filename: Line: 413)

    ) = 24
    munmap(0xfffffffff4de5000, 1052672) = 0
    munmap(0xfffffffff4ee6000, 528384) = 0
    semop(67960838, {{3, -1, SEM_UNDO}}, 1) = 0
    time(NULL) = 1406062775
    semop(67960838, {{3, 1, SEM_UNDO}}, 1) = 0
    semop(67960838, {{3, -1, SEM_UNDO}}, 1) = 0
    semop(67960838, {{3, 1, SEM_UNDO}}, 1) = 0
    semop(67960838, {{6, -1, SEM_UNDO}}, 1) = 0
    semctl(67960838, 7, IPC_64|GETVAL, 0xfffffffffff6f538) = 1
    semctl(67960838, 0, IPC_64|IPC_RMID, 0xfffffffffff6f538) = 0
    uname({sys=”Linux”, node=”quad”, …}) = 0
    uname({sys=”Linux”, node=”quad”, …}) = 0
    getuid32() = 1000
    unlink(“/dev/shm/mono-shared-1000-shared_data-quad-Linux-x86_64-312-12-0″) = 0
    uname({sys=”Linux”, node=”quad”, …}) = 0
    uname({sys=”Linux”, node=”quad”, …}) = 0
    getuid32() = 1000
    unlink(“/dev/shm/mono-shared-1000-shared_fileshare-quad-Linux-x86_64-36-12-0″) = 0
    uname({sys=”Linux”, node=”quad”, …}) = 0
    uname({sys=”Linux”, node=”quad”, …}) = 0
    unlink(“/home/user/.wapi/shared_data-quad-Linux-x86_64-312-12-0″) = -1 ENOENT (No such file or directory)
    uname({sys=”Linux”, node=”quad”, …}) = 0
    uname({sys=”Linux”, node=”quad”, …}) = 0
    unlink(“/home/user/.wapi/shared_fileshare-quad-Linux-x86_64-36-12-0″) = -1 ENOENT (No such file or directory)
    unlink(“/dev/shm/mono.14348″) = 0
    getpid() = 14348
    exit_group(0) = ?
    +++ exited with 0 +++

    I do not have any mono/MouseCraft process running, so really not sure why it’s thinking it’s already running and removing the ~/.config/Crunching\ Koalas do not make any difference.

    Please tell what’s wrong.

    #5210
    Tom
    Tom
    CRUNCHING KOALA

    Joined: 10/25/2012

    Posts: 92

    Hey

    Can you please me what version of Linux you’re using?

    Cheers,
    Tom

    #5211

    Trizt
    Member

    Joined: 8/3/2013

    Posts: 1

    Distribution: Gentoo
    Branch: Stable with ~ KDE
    Kernel: 3.10.48
    Architecture: amd64

    MouseCraft installed: 9th July
    Last day working: 13th July

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.